标签:
Stupid Tower Defense
Time Limit: 12000/6000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1759 Accepted Submission(s): 498
Problem Description
FSF is addicted to a stupid tower defense game. The goal of tower defense games is to try to stop enemies from crossing a map by building traps to slow them down and towers which shoot at them as they pass.
The map is a line, which has n unit length. We can build only one tower on each unit length. The enemy takes t seconds on each unit length. And there are 3 kinds of tower in this game: The red tower, the green tower and the blue tower.
The red tower damage on the enemy x points per second when he passes through the tower.
The green tower damage on the enemy y points per second after he passes through the tower.
The blue tower let the enemy go slower than before (that is, the enemy takes more z second to pass an unit length, also, after he passes through the tower.)
Of course, if you are already pass through m green towers, you should have got m*y damage per second. The same, if you are already pass through k blue towers, the enemy should have took t + k*z seconds every unit length.
FSF now wants to know the maximum damage the enemy can get.
Input
There are multiply test cases.
The first line contains an integer T (T<=100), indicates the number of cases.
Each test only contain 5 integers n, x, y, z, t (2<=n<=1500,0<=x, y, z<=60000,1<=t<=3)
Output
For each case, you should output "Case #C: " first, where C indicates the case number and counts from 1. Then output the answer. For each test only one line which have one integer, the answer to this question.
Sample Input
Sample Output
Case #1: 12
Hint
For the first sample, the first tower is blue tower, and the second is red tower. So, the total damage is 4*(1+2)=12 damage points.
Author
UESTC
Source
Recommend
We have carefully selected several similar problems for you:
5245 5244 5243 5242 5241
看人家的http://blog.csdn.net/LYHVOYAGE/article/details/38531575
ac代码
#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
__int64 dp[1510][1510];
__int64 n,x,y,z,t;
int main()
{
int cas,cot=0;
scanf("%d",&cas);
while(cas--)
{
scanf("%I64d%I64d%I64d%I64d%I64d",&n,&x,&y,&z,&t);
memset(dp,0,sizeof(dp));
__int64 ans=n*t*x;
int i,j;
for(i=1;i<=n;i++)
{
for(j=0;j<=i;j++)
{
if(j==0)
dp[i][j]=dp[i-1][j]+(i-1-j)*y*t;
else
{
__int64 temp1,temp2;
temp1=dp[i-1][j-1]+(i-j)*y*(t+(j-1)*z);
temp2=dp[i-1][j]+(i-j-1)*y*(t+j*z);
dp[i][j]=max(temp1,temp2);
}
ans=max(ans,dp[i][j]+(n-i)*x*(t+j*z)+(n-i)*y*(i-j)*(t+j*z));
}
}
printf("Case #%d: %I64d\n",++cot,ans);
}
}
HDOJ题目4939 Stupid Tower Defense(dp)
标签:
原文地址:http://blog.csdn.net/yu_ch_sh/article/details/46050091