码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1656 Counting Black

时间:2015-05-28 08:13:41      阅读:115      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 10509   Accepted: 6786

Description

There is a board with 100 * 100 grids as shown below. The left-top gird is denoted as (1, 1) and the right-bottom grid is (100, 100).
技术分享

We may apply three commands to the board:

1. WHITE x, y, L // Paint a white square on the board,
// the square is defined by left-top grid (x, y)
// and right-bottom grid (x+L-1, y+L-1)

2. BLACK x, y, L // Paint a black square on the board,
// the square is defined by left-top grid (x, y)
// and right-bottom grid (x+L-1, y+L-1)

3. TEST x, y, L // Ask for the number of black grids
// in the square (x, y)- (x+L-1, y+L-1)

In the beginning, all the grids on the board are white. We apply a series of commands to the board. Your task is to write a program to give the numbers of black grids within a required region when a TEST command is applied.

Input

The first line of the input is an integer t (1 <= t <= 100), representing the number of commands. In each of the following lines, there is a command. Assume all the commands are legal which means that they won‘t try to paint/test the grids outside the board.

Output

For each TEST command, print a line with the number of black grids in the required region.

Sample Input

5
BLACK 1 1 2
BLACK 2 2 2
TEST 1 1 3
WHITE 2 1 1
TEST 1 1 3

Sample Output

7
6

CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)

using namespace std;

int main(){
    int T; scanf("%d", &T);
    int map[100 + 10][100 + 10];
    memset(map, 0, sizeof(map));
    char s[7];
    while(T --){
        scanf("%s", s);
        int x, y, l; 
        scanf("%d%d%d", &x, &y, &l);
        if(s[0] == B){
            REP(i, x, x + l - 1) REP(j, y, y + l - 1)
                map[i][j] = 1;
        }
        else if(s[0] == W){
            REP(i, x, x + l - 1) REP(j, y, y + l - 1)
                map[i][j] = 2;
        }
        else if(s[0] == T){
            int ans = 0;
            REP(i, x, x + l - 1) REP(j, y, y + l - 1)
                if(map[i][j] == 1) ans ++;
            printf("%d\n", ans);
        }
    }
    return 0;
}    

 

 

POJ 1656 Counting Black

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4534950.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!