码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1936 All in All

时间:2015-05-28 08:13:56      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 29241   Accepted: 12136

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

不要要求连续匹配,直接模拟
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 100000 + 10

using namespace std;

char s[MAX_N], t[MAX_N];
int ls, lt;

int main(){
    while(scanf("%s %s", s + 1, t + 1) != EOF){
        ls = strlen(s + 1); lt = strlen(t + 1);
        int node_s = 1, node_t = 1;
        bool match[MAX_N];
        memset(match, 0, sizeof(match));
        while(node_s <= ls && node_t <= lt){
            if(s[node_s] == t[node_t]) match[node_s] = 1, node_s ++, node_t ++;
            else node_t ++;
        }
        bool tmp = 1;
         REP(i, 1, ls) if(!match[i]){ tmp = 0; break; }
        
        if(tmp) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
} 

 


POJ 1936 All in All

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4534943.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!