标签:
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 3871 | Accepted: 2028 |
Description
We give the following inductive definition of a “regular brackets” sequence:
For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence ([([]])]
, the longest regular brackets subsequence is [([])]
.
Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (
, )
, [
, and ]
; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.
Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.
Sample Input
((())) ()()() ([]]) )[)( ([][][) end
Sample Output
6 6 4 0 6
#include<stdio.h>
#include<string.h>
#define max(x,y) x>y?x:y
int main(){char sequence[110];
int dp[105][105],t;
while(scanf("%s",sequence),strcmp(sequence,"end")){
memset(dp,0,sizeof(dp));
t=strlen(sequence);
for(int i=t-2;i>=0;i--){
for(int j=i+1;j<t;j++){dp[i][j]=dp[i+1][j];
for(int k=i+1;k<=j;k++){
if(sequence[i]==‘(‘&&sequence[k]==‘)‘||sequence[i]==‘[‘&&sequence[k]==‘]‘){
dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k][j]+2);
// printf("%d %d %c %c %d\n",i,k,sequence[i],sequence[k],dp[i][k]);
}
}
}
}
printf("%d\n",dp[0][t-1]);
}
return 0;
}
标签:
原文地址:http://www.cnblogs.com/handsomecui/p/4534995.html