码迷,mamicode.com
首页 > 其他好文 > 详细

POJ_3069_Saruman's Army(贪心)

时间:2015-05-28 14:11:10      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:acm   algorithm   poj   greedy   

Saruman‘s Army
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5049   Accepted: 2617

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = ?1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题意:直线上有N个点。点i的位置是Xi。从这N个点中选取若干个,给他们加上标记。对每一个点,其距离为R以内的区域里必须有带有标记的点(自己本身带有标记的点,可以认为与其距离为0的地方有一个带有标记的点)。在满足这个条件的情况下,希望能为尽可能少的点添加标记。请问至少要有多少点被加上标记?

分析:贪心题。先考虑第一个被标记的点,毫无疑问,该点为距第一个点R以内的最远的点,这个点标记后,左边的区域就没有覆盖意义了(因为已经覆盖了),所以此时我们应该尽可能覆盖更右边的点。依次类推得到最终解。

题目链接:http://poj.org/problem?id=3069

代码清单:

#include<map>
#include<set>
#include<queue>
#include<stack>
#include<cmath>
#include<ctime>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn = 1000 + 5;

int R,n;
int point[maxn];

void input(){
    for(int i=0;i<n;i++){
        scanf("%d",&point[i]);
    }
}

void solve(){
    int ans=0,head=0,tail=0;
    sort(point,point+n);
    while(true){
        while(tail+1<n&&point[tail+1]-R<=point[head]){
            tail++;
        }
        head=tail;
        ans++;
        while(tail+1<n&&point[head]+R>=point[tail+1]){
            tail++;
        }
        if(tail==n-1) break;
        head=++tail;
    }
    printf("%d\n",ans);
}

int main(){
    while(scanf("%d%d",&R,&n)!=EOF){
        if(R==-1&&n==-1) break;
        input();
        solve();
    }return 0;
}


POJ_3069_Saruman's Army(贪心)

标签:acm   algorithm   poj   greedy   

原文地址:http://blog.csdn.net/jhgkjhg_ugtdk77/article/details/46120955

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!