码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1019- Number Sequence(规律定位)

时间:2015-05-28 14:12:39      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:数学   数论   规律   

Number Sequence
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2

题意:在给出的数字串中定位位置。

思路:然而这个字符串是有规律的,1   12   123   1234   12345   123456 and so on(然而要注意多位的数是要分开来看的,Eg 10要看成1和0)

首先当然要把1   12   123   1234  分开组,先计算一下到第i组的时候与多少位数,以及前i组一共有多少个数,对int熟悉的巨巨们应该知道2147483647刚好是int的正整数最大极限值,然而有31268组即可。
然后对于给出的提问数字n,先判断在哪一组数到哪一组数之间,然后再判断那一位是什么。

特别注意的是log()和pow()函数的使用

两个都是重载函数,函数原型分别为
double log(double)
float log(float)
double pow(double , double)
float pow(float ,float)
所以当传参的类型不是double或float时,必须强制转换为其中一种类型,否则编译出错。一般建议用double

PS:详情请看------.>点击打开链接

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double eps=1e-10;
const double pi= acos(-1.0);
const int MAXN=31269;
LL a[MAXN];//第i组序列的长度
LL b[MAXN];//前i组序列的长度
void Init()//
{
    a[1]=b[1]=1;
    for(int i=2;i<MAXN;i++){
        a[i]=a[i-1]+(int)log10((double)i)+1;//log10(i)+1 表示第i组数字列的长度 比 第i-1组 长的位数
        b[i]=b[i-1]+a[i];//前i组的长度s[i] 等于 前i-1组的长度s[i-1] + 第i组的长度a[i]
    }
}
int Find(int n)
{
    int i=1;
    while(b[i]<n)
        i++;//确定整个数字序列的第n个位置出现在第i组
    int pos=n-b[i-1];//pos为 整个数字序列的第n个位置 在 第i组中的下标值
    int len=0;
    for(i=1;len<pos;i++)
        len+=(int)log10((double)i)+1;
    return (i-1)/(int)pow((double)10,len-pos)%10;
    //之所以i-1,是因为前面寻找第i组长度时,i++多执行了一次  
           //i=i-1 此时i刚好等于第n位个置上的数 (数是整体,例如123一百二十三,i刚好等于123,但n指向的可能是1,2或3)  
           //pos为n指向的数字在第i组中的下标值  
           //len为第i组的长度  
           //那么len-pos就是第i组中pos位置后多余的数字位数  
           //则若要取出pos位上的数字,就要利用(i-1)/pow(10,len-pos)先删除pos后多余的数字  
           //再对剩下的数字取模,就可以得到pos  
           //例如要取出1234的2,那么多余的位数有2位:34。那么用1234 / 10^2,得到12,再对12取模10,就得到2  
  
}

int main()
{
    int T,n;
    Init();
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        printf("%d\n",Find(n));
    }
    return 0;
}


POJ 1019- Number Sequence(规律定位)

标签:数学   数论   规律   

原文地址:http://blog.csdn.net/u013486414/article/details/46120301

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!