码迷,mamicode.com
首页 > 其他好文 > 详细

一些项目——Fibonacci Again

时间:2015-05-28 18:06:50      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:c++   编程   数据   cpp   信息   

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no


代码

#include <iostream>
using namespace std;
int main()
{
    long n;
    while(cin>>n)
    {
        if(n>0&&(n-2)%4==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
    return 0;
}

计算一下前100个数列的值可以发现,从f(2)开始,每过4个数就能被3整除,所以只要看输入的值减去2是不是能被4整除就行。


一些项目——Fibonacci Again

标签:c++   编程   数据   cpp   信息   

原文地址:http://blog.csdn.net/blue_skyrim/article/details/46125757

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!