标签:c++ 数据 编程 cpp c
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All
integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
代码
#include <stdio.h>
#include <iomanip>
#include <algorithm>
#include <cmath>
using namespace std;
struct Node
{
double j,f,p;
} s[10000];
int cmp(Node x,Node y)
{
return x.p>y.p;
}
int main()
{
int n,i;
double sum,m;
while(~scanf("%lf%d",&m,&n) && (m!=-1 || n!=-1))
{
sum=0;
for(i=0; i<n; ++i)
{
scanf("%lf%lf",&s[i].j,&s[i].f);
s[i].p=s[i].j/s[i].f;
}
sort(s,s+n,cmp);
for(i=0; i<n; ++i)
{
if(m>s[i].f)
{
sum+=s[i].j;
m-=s[i].f;
}
else
{
sum+=s[i].p*m;
break;
}
}
printf("%.3lf\n",sum);
}
return 0;
}
完全同样的步骤,用C++语言就答案错误,用C语言就正确,真是醉了,看来要重学C?
一些项目——FatMouse' Trade
标签:c++ 数据 编程 cpp c
原文地址:http://blog.csdn.net/blue_skyrim/article/details/46134893