码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3292-Semi-prime H-numbers(筛选法)

时间:2015-05-29 14:06:36      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:筛选法   数论   

Semi-prime H-numbers
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it‘s the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

题意:

H-number是所有的4K+1的数,K是整数。

H-primes 是当且仅当它的因数只有1和它本身(除1外)

H-semi-prime当且仅当它只由两个H-primes的乘积表示

H-number剩下其他的数均为H-composite。
如果一个H-number是H-primes 。一个H-number是H-semi-prime,给你一个数n,问1到n有多少个H-semi-prime数。


#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double eps=1e-10;
const double pi= acos(-1.0);
const int MAXN=1e6+10;
int a[MAXN];
int b[MAXN];
void Init()
{
    int i,j;
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    for(i=5;i<=MAXN;i+=4){
        for(j=5;j<=MAXN;j+=4){
            if(i*j>MAXN) break;
            if(a[i]==0&&a[j]==0)
                a[i*j]=1;
            else
                a[i*j]=2;
        }
    }
    int cnt=0;
    for(i=1;i<=MAXN;i++){
        if(a[i]==1)
            cnt++;
        b[i]=cnt;
    }
}

int main()
{
    int n;
    Init();
    while(~scanf("%d",&n)){
        if(!n) break;
        printf("%d %d\n",n,b[n]);
    }
    return 0;
}


POJ 3292-Semi-prime H-numbers(筛选法)

标签:筛选法   数论   

原文地址:http://blog.csdn.net/u013486414/article/details/46228431

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!