码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-1037-Keep on Truckin'(HDU最水的题没有之一,为了练英语就来吧)

时间:2015-05-30 14:57:21      阅读:112      评论:0      收藏:0      [点我收藏+]

标签:hdu   最水的题   英语蛋疼   不解释   

Keep on Truckin‘

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10324    Accepted Submission(s): 7147


Problem Description
Boudreaux and Thibodeaux are on the road again . . .

"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"

"Don‘t worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"

"We‘re not going to make it, I say!"

So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?
 

Input
Input to this problem will consist of a single data set. The data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.
 

Output
There will be exactly one line of output. This line will be:

   NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

   CRASH X

otherwise, where X is the height of the first underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler). 
The height of the 18-wheeler is 168 inches.
 

Sample Input
180 160 170
 

Sample Output
CRASH 160
 

Source
 

Recommend
We have carefully selected several similar problems for you:  1040 1032 1064 1038 1056 


HDU,最水,英语看的脑子都是大的.
题意是说输入三个数,如果三个数都比168大,那么输出NO CRASH;否则输出第一个出现小于等于168的那个数!
如果你能从这段英文看出这个意思来,恭喜你,你赢了。反正我是没看出来!!

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int a,b,c;
    while(scanf("%d%d%d",&a,&b,&c)!=EOF)
    {
        if(a>168&&b>168&&c>168)
        {
            cout<<"NO CRASH"<<endl;
        }
        else if(a<168)
        {
            cout<<"CRASH "<<a<<endl;
        }
        else if(b<168)
        {
            cout<<"CRASH "<<b<<endl;
        }
        else if(c<168)
        {
            cout<<"CRASH "<<c<<endl;
        }
    }
    return 0;
}




 

HDU-1037-Keep on Truckin'(HDU最水的题没有之一,为了练英语就来吧)

标签:hdu   最水的题   英语蛋疼   不解释   

原文地址:http://blog.csdn.net/qq_16542775/article/details/46274015

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!