标签:c++ cpp 数据 编程 类
Problem Description
A triangle field is numbered with successive integers in the way shown on the picture below.
The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length
of the traveller‘s route.
Write the program to determine the length of the shortest route connecting cells with numbers N and M.
Input
Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).
Output
Output should contain the length of the shortest route.
Sample Input
Sample Output
代码
#include<stdio.h>
#include<math.h>
void find(int n,int &l,int &r,int &level)
{
int i;
level=1;
for(i=1;;i+=2)
{
if(n-i<=0)
{
l=(n+1)/2;
r=(i-n)/2+1;
break;
}
level++;
n-=i;
}
}
int main()
{
int m,n;
int ml,mr,nl,nr,mlevel,nlevel;
while(scanf("%d%d",&m,&n)!=EOF)
{
find(m,ml,mr,mlevel);
find(n,nl,nr,nlevel);
printf("%d\n",abs(ml-nl)+abs(mr-nr)+abs(mlevel-nlevel));
}
return 0;
}
一些项目——Delta-wave
标签:c++ cpp 数据 编程 类
原文地址:http://blog.csdn.net/blue_skyrim/article/details/46275867