码迷,mamicode.com
首页 > 其他好文 > 详细

一些项目——Delta-wave

时间:2015-05-30 18:18:12      阅读:96      评论:0      收藏:0      [点我收藏+]

标签:c++   cpp   数据   编程      

Problem Description

A triangle field is numbered with successive integers in the way shown on the picture below. 

技术分享


The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length of the traveller‘s route. 

Write the program to determine the length of the shortest route connecting cells with numbers N and M. 

Input

Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).

Output

Output should contain the length of the shortest route.

Sample Input

6 12 

Sample Output

3


代码

#include<stdio.h>
#include<math.h>
void find(int n,int &l,int &r,int &level)
{
    int i;
    level=1;
    for(i=1;;i+=2)
    {
        if(n-i<=0)
        {
            l=(n+1)/2;
            r=(i-n)/2+1;
            break;
        }
        level++;
        n-=i;
    }
}
int main()
{
    int m,n;
    int ml,mr,nl,nr,mlevel,nlevel;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        find(m,ml,mr,mlevel);
        find(n,nl,nr,nlevel);
        printf("%d\n",abs(ml-nl)+abs(mr-nr)+abs(mlevel-nlevel));
    }
    return 0;
}


一些项目——Delta-wave

标签:c++   cpp   数据   编程      

原文地址:http://blog.csdn.net/blue_skyrim/article/details/46275867

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!