码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3086 Triangular Sums

时间:2015-06-01 09:30:57      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6587   Accepted: 4687

Description

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…n; k * T(k + 1)]

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.

Output

For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.

Sample Input

4
3
4
5
10

Sample Output

1 3 45
2 4 105
3 5 210
4 10 2145

CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <climits>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 300 + 10

using namespace std;

int n, x;
int sum[MAX_N];

int main(){
    sum[0] = 0;
    REP(i, 1, MAX_N) sum[i] = sum[i - 1] + i;
    scanf("%d", &n);
    REP(i, 1, n){
        scanf("%d", &x);
        int res = 0;
        REP(i, 1, x) res += sum[i + 1] * i;
        printf("%d %d %d\n", i, x, res);
    }
    return 0;
}

 

 

POJ 3086 Triangular Sums

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4543189.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!