码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1663 Number Steps

时间:2015-06-01 11:11:00      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 13640   Accepted: 7361

Description

Starting from point (0,0) on a plane, we have written all non-negative integers 0,1,2, ... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.
技术分享

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

Output

For each point in the input, write the number written at that point or write No Number if there is none.

Sample Input

3
4 2
6 6
3 4

Sample Output

6
12
No Number

找规律
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)

using namespace std;

int main(){
    int T; scanf("%d", &T);
    while(T --){
        int x, y; scanf("%d%d", &x, &y);
        if(x == y){
            if(x % 2 == 1) printf("%d\n", x / 2 * 4 + 1);
            else printf("%d\n", x * 2);
        }
        else if(x - y == 2){
            if(y % 2 == 1) printf("%d\n", (y / 2) * 4 + 3);
            else printf("%d\n", (y / 2) * 4 + 2);
        }
        else printf("No Number\n");
    }
    return 0;
}

 

 

POJ 1663 Number Steps

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4543331.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!