码迷,mamicode.com
首页 > 其他好文 > 详细

ACM——A + B Problem (4)

时间:2014-06-18 13:58:31      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:style   class   blog   code   java   tar   

A + B Problem (4)

时间限制(普通/Java):1000MS/3000MS          运行内存限制:65536KByte
总提交:2496            测试通过:1249

描述

Calculate the sum of some integers.

输入

The input will consist of multiple test cases. Each test case consist of an integer N and then N integers following in the same line,separated by a space. A line starting with 0 terminates the input and this line is not to be processed.

输出

For test case, you should output their sum in one line, and with one line of output for each line in input. After each test case output, you should output one blank line.

样例输入

4 1 2 3 4
5 1 2 3 4 5
0

样例输出

10

15

题目来源

HDUOJ

 

#include<iostream>
#include<vector>
using namespace std;
int main(){
    int i,a,b;
    vector<int> ivec;
    int sum=0;
    while(cin>>a)
    {
        if(a==0)
            break;
        for(i=0;i<a;i++)
        {
            cin>>b;
            sum+=b;
        }
        ivec.push_back(sum);
        sum=0;
    }
    for(i=0;i<ivec.size();i++)
        cout<<ivec[i]<<endl<<endl;
    return 0;
}

 

 

 

ACM——A + B Problem (4),布布扣,bubuko.com

ACM——A + B Problem (4)

标签:style   class   blog   code   java   tar   

原文地址:http://www.cnblogs.com/BasilLee/p/3791831.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!