码迷,mamicode.com
首页 > 其他好文 > 详细

【UVA401】Palindromes

时间:2015-06-03 13:41:40      阅读:94      评论:0      收藏:0      [点我收藏+]

标签:

Palindromes

Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu

Appoint description:

Description

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

 


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others‘ reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string.

Of course,"A","T", "O", and "Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

Character Reverse Character Reverse Character Reverse
A A M M Y Y
B   N   Z 5
C   O O 1 1
D   P   2 S
E 3 Q   3 E
F   R   4  
G   S 2 5 Z
H H T T 6  
I I U U 7  
J L V V 8 8
K   W W 9  
L J X X    


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRING CRITERIA
" -- is not a palindrome." if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome." if the string is a palindrome and is not a mirrored string
" -- is a mirrored string." if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string

Note that the output line is to include the -‘s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

Sample Output

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.

Hint

use the C++‘s class of string will be convenient, but not a must


题意:判断一个字符串是不是回文串和镜像串

题解:题目很简单  简单模拟可能会写起来稍微麻烦一点 照着紫书的代码敲了一遍 自己写的用到了string时间略长 这里就不放出来了 看了下书上说这道题考察字符数组和常量数组的应用 感觉这些简单的题目一些小技巧类的东西还是需要注意一点的

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const char* rev = "A   3  HIL JM O   2TUVWXY51SE Z  8 ";
const char* msg[] = {"not a palindrome.", "a regular palindrome.", "a mirrored string.", "a mirrored palindrome."};

char r(char ch);

int main(){
	char s[30];
	while(scanf("%s", s) != EOF){
		int len = strlen(s);
		int p = 1, m = 1;
		for(int i = 0; i < (len+1)/2; ++i){
			if(s[i] != s[len-1-i]){
				p = 0;
			}

			if(r(s[i]) != s[len-1-i]){
				m = 0;
			}
		}

		printf("%s -- is %s\n\n", s, msg[m*2+p]);
	}
	return 0;
}

char r(char ch){
	if(isalpha(ch)){
		return rev[ch - 'A'];
	}

	return rev[ch - '0' + 25];
}


【UVA401】Palindromes

标签:

原文地址:http://blog.csdn.net/u012431590/article/details/46344091

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!