标签:
Lowest Bit
最低的位
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9436 Accepted Submission(s): 6935
Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.
给一个正整数A,输出A的最后一位
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
举一个例子:例如A=26,我们可以以二进制形式写一个 11010,所以最低位的是10,因此输出2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
再举一个例子:例如A=88,我们可以写一个以二进制形式为 1011000,所以最低位是 1000,因此输出8.
Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
每一行输入一个A,当A=0时,代表输入结束,且这行数据不做处理。
Output
For each A in the input, output a line containing only its lowest bit.
在单独的一行输出最低的位.
Sample Input
Sample Output
Author
SHI, Xiaohan
Source
水题
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while (sc.hasNext()) {
int a = sc.nextInt();
if (a == 0) {
return;
}
byte by = 1;
for (int i = 0; i < a; i++) {
if ((a & by) == by) {
System.out.println(by);
break;
}
by *= 2;
}
}
}
}
Lowest Bit
标签:
原文地址:http://blog.csdn.net/hncu1306602liuqiang/article/details/46343469