码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3264 Balanced Lineup

时间:2015-06-04 08:37:32      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 38139   Accepted: 17863
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

随手打了个线段树,竟然A了,但是慢的一比、、、、
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define max(a, b) a > b ? a : b
#define min(a, b) a < b ? a : b 
#define MAX_N 50000 + 10

using namespace std;

int n, q, data[MAX_N];
struct node{
    int l, r, mx, mn;
}a[MAX_N << 2];

void update(int i){
    int t1 = i << 1, t2 = t1 + 1;
    a[i].mx = max(a[t1].mx, a[t2].mx);
    a[i].mn = min(a[t1].mn, a[t2].mn);
}

void maketree(int i, int l, int r){
    a[i].l = l; a[i].r = r;
    if(a[i].l == a[i].r){
        a[i].mx = data[l]; a[i].mn = data[l];
        return;
    }
    
    int mid = (a[i].l + a[i].r) >> 1, t1 = i << 1, t2 = t1 + 1;
    maketree(t1, l, mid); maketree(t2, mid + 1, r);
    update(i);
}

int Query_Max(int i, int l, int r){
    if(a[i].l == l && a[i].r == r) return a[i].mx;
    
    int mid = (a[i].l + a[i].r) >> 1, t1 = i << 1, t2 = t1 + 1;
    
    if(r <= mid) return Query_Max(t1, l, r);
    else if(l > mid) return  Query_Max(t2, l, r);
    else return max(Query_Max(t1, l, mid), Query_Max(t2, mid + 1, r));
}

int Query_Min(int i, int l, int r){
    if(a[i].l == l && a[i].r == r) return a[i].mn;
    
    int mid = (a[i].l + a[i].r) >> 1, t1 = i << 1, t2 = t1 + 1;
    
    if(r <= mid) return Query_Min(t1, l, r);
    else if(l > mid) return  Query_Min(t2, l, r);
    else return min(Query_Min(t1, l, mid), Query_Min(t2, mid + 1, r));
}
        
int main(){
    scanf("%d%d", &n, &q);
    REP(i, 1, n) scanf("%d", &data[i]);
    maketree(1, 1, n);
    
    int x, y;
    while(q --){
        scanf("%d%d", &x, &y);
        printf("%d\n", Query_Max(1, x, y) - Query_Min(1, x, y));
    }
    return 0;
}

 

 

POJ 3264 Balanced Lineup

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4550786.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!