码迷,mamicode.com
首页 > 其他好文 > 详细

light_oj 1236 求最小公倍数( lcm(a,b) )等于n的数对 素因数分解

时间:2015-06-04 22:36:18      阅读:357      评论:0      收藏:0      [点我收藏+]

标签:

light_oj 1236 求最小公倍数( lcm(a,b) )等于n的数对  素因数分解

H - Pairs Forming LCM
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Find the result of the following code:

long long pairsFormLCM( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        for( int j = i; j <= n; j++ )
           if( lcm(i, j) == n ) res++; // lcm means least common multiple
    return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function ‘pairsFormLCM(n)‘.

Sample Input

15

2

3

4

6

8

10

12

15

18

20

21

24

25

27

29

Sample Output

Case 1: 2

Case 2: 2

Case 3: 3

Case 4: 5

Case 5: 4

Case 6: 5

Case 7: 8

Case 8: 5

Case 9: 8

Case 10: 8

Case 11: 5

Case 12: 11

Case 13: 3

Case 14: 4

Case 15: 2

题意:对给定的n,求符合lcm(a,b)==n的(a,b)的数对的个数。
思路:对n进行素数分解,a和b与n对应分解
     n=p1^e1*p2^e2*...*pk^ek;
     a=p1^a1*p2^a2*…*pk^ak
     b=p1^b1*p2^b2*…*pk^bk
对于a,b它们的最小公倍数为n,则a1<=e1,b1<=e1,则(a1,b1)有2*(e1+1)-1对则总的对数有t=(2*e1+1)*(2*e2+1)....,其中除了(n,n),其他的都重复了两次则答案为(t+1)/2.
注意由于n的范围是10^14,因此素数筛到10^7,然而还是会漏过素因子,但显然只会漏过最多一个素因子,因为sqrt(10^14)==10^7,如果有两个大于10^7的素因子,根据素数分解公式,必定含有这两个大于10^7的素因子,相乘一定大于10^14大于n,与分解等式矛盾。因此只需最后特判最后一个即可。
技术分享
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<map>
#include<string>
#include<math.h>
#include<cctype>

using namespace std;

typedef long long ll;
const int maxn=10000100;
const int INF=(1<<29);
const double EPS=0.0000000001;
const double Pi=acos(-1.0);

int T;
ll n;
vector<ll> prime;
bool isprime[maxn];

void play_prime()
{
    memset(isprime,1,sizeof(isprime));
    isprime[1]=0;
    for(int i=2;i<maxn;i++){
        if(!isprime[i]) continue;
        for(int j=i*2;j<maxn;j+=i) isprime[j]=0;
    }
    for(int i=1;i<maxn;i++) if(isprime[i]) prime.push_back(i);
}

int main()
{
    int tag=1;
    cin>>T;
    play_prime();
    while(T--){
        cin>>n;
        ll ans=1;
        for(int i=0;i<prime.size()&&prime[i]<=n;i++){
            ll t=prime[i];
            int cnt=0;
            while(n%t==0){
                n/=t;
                cnt++;
            }
            ans*=(2*cnt+1);
        }
        if(n>1) ans*=(2*1+1);
        ans=(ans+1)/2;
        printf("Case %d: %lld\n",tag++,ans);
    }
    return 0;
}
View Code

 

light_oj 1236 求最小公倍数( lcm(a,b) )等于n的数对 素因数分解

标签:

原文地址:http://www.cnblogs.com/--560/p/4552948.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!