码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3249 Test for Job (DAG最长路 记忆化搜索解决)

时间:2014-06-18 11:17:50      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   code   http   

Test for Job
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 8990   Accepted: 2004

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It‘s hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases. 
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads. 
The next n lines each contain a single integer. The ith line describes the net profit of the city iVi (0 ≤ |Vi| ≤ 20000) 
The next m lines each contain two integers xy indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city. 

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint

bubuko.com,布布扣

Source



题意:

给你一个图,求一条起点(入度为0)到终点(出度为0)的路,满足所有点的val之和最大。


思路:

开始想的是SPFA,然后无尽的TLE,后来用记忆化搜索过了。

有一个简单的小处理就是增加一个源点对所有的起点建边。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define maxn 100005
#define MAXN 2000005
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;

ll n,m,ans,cnt,sx,oo;
bool vis[maxn];
ll dp[maxn],head[maxn];
ll in[maxn],val[maxn];
struct Node
{
    ll v,w,next;
}edge[MAXN];

void addedge(ll u,ll v,ll w)
{
    cnt++;
    edge[cnt].v=v;
    edge[cnt].w=w;
    edge[cnt].next=head[u];
    head[u]=cnt;
}
ll dfs(ll u)
{
    if(dp[u]!=oo) return dp[u];
    ll i,j,t,v,best=oo,flg=0;
    for(i=head[u];i;i=edge[i].next)
    {
        flg=1;
        v=edge[i].v;
        dfs(v);
        best=max(best,dp[v]);
    }
    if(flg) dp[u]=best+val[u];
    else dp[u]=val[u];
}
int main()
{
    ll i,j,u,v,w;
    oo=-(1LL<<50);
    while(~scanf("%lld%lld",&n,&m))
    {
        for(i=1;i<=n;i++)
        {
            scanf("%lld",&val[i]);
        }
        cnt=0;
        for(i=0;i<=n;i++) head[i]=in[i]=0;
        for(i=1;i<=m;i++)
        {
            scanf("%lld%lld",&u,&v);
            addedge(u,v,val[u]);
            in[v]++;
        }
        for(i=1;i<=n;i++)
        {
            if(in[i]==0) addedge(0,i,0);
        }
        for(i=0;i<=n;i++) dp[i]=oo;
        dfs(0);
        printf("%lld\n",dp[0]);
    }
    return 0;
}





poj 3249 Test for Job (DAG最长路 记忆化搜索解决),布布扣,bubuko.com

poj 3249 Test for Job (DAG最长路 记忆化搜索解决)

标签:des   style   class   blog   code   http   

原文地址:http://blog.csdn.net/tobewhatyouwanttobe/article/details/31462333

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!