码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ 587 blockhouses 【DFS】

时间:2014-06-21 22:36:56      阅读:316      评论:0      收藏:0      [点我收藏+]

标签:nyoj 587

blockhouses

时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 

bubuko.com,布布扣

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
输入
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file.
输出
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
样例输入
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0
样例输出
5
1
5
2
4

#include <stdio.h>
char map[6][6];
int vis[6][6];
int n, max, count;

void getFireRange(int row, int col){
	int i = 1;
	while(row + i < n){ //向下开火
		if(map[row+i][col] == 'X') break;
		++vis[row+i][col]; ++i;
	}
	i = 1;
	while(row - i >= 0){
		if(map[row-i][col] == 'X') break;
		++vis[row-i][col]; ++i;
	}
	i = 1;
	while(col - i >= 0){
		if(map[row][col-i] == 'X') break;
		++vis[row][col-i]; ++i;
	}
	i = 1;
	while(col + i < n){
		if(map[row][col+i] == 'X') break;
		++vis[row][col+i]; ++i;
	}
}

void cancelFireRange(int row, int col){
	int i = 1;
	while(row + i < n){ //向下开火
		if(map[row+i][col] == 'X') break;
		--vis[row+i][col]; ++i;
	}
	i = 1;
	while(row - i >= 0){
		if(map[row-i][col] == 'X') break;
		--vis[row-i][col]; ++i;
	}
	i = 1;
	while(col - i >= 0){
		if(map[row][col-i] == 'X') break;
		--vis[row][col-i]; ++i;
	}
	i = 1;
	while(col + i < n){
		if(map[row][col+i] == 'X') break;
		--vis[row][col+i]; ++i;
	}
}

bool check(int i, int j){
	if(map[i][j] == 'X' || vis[i][j]) return 0;//火力覆盖或者已有碉堡
	return 1;
}

void DFS(int row, int col){
	for( ; row < n; ++row, col = 0){
		for( ; col < n; ++col){
			if(map[row][col] == '.' && check(row, col)){
				vis[row][col] = 1; ++count;
				if(count > max) max = count;
				getFireRange(row, col);
				DFS(row, col + 1);
				cancelFireRange(row, col);
				vis[row][col] = 0; --count;
			}
		}
	}
}

int main(){
	while(scanf("%d", &n), n){		
		for(int i = 0; i < n; ++i){
			getchar();
			for(int j = 0; j < n; ++j){
				map[i][j] = getchar();
				vis[i][j] = 0;
			}
		}
		max = count = 0;
		DFS(0, 0); //从第0行第0列开始
		printf("%d\n", max);
	}
	return 0;
}


NYOJ 587 blockhouses 【DFS】,布布扣,bubuko.com

NYOJ 587 blockhouses 【DFS】

标签:nyoj 587

原文地址:http://blog.csdn.net/chang_mu/article/details/32107675

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!