码迷,mamicode.com
首页 > 其他好文 > 详细

矩形类定义

时间:2014-06-25 20:06:21      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:des   class   blog   code   http   tar   

矩形类定义【C++】Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 472  Solved: 301
[Submit][Status][Web Board]

Description

定义一个矩形类,数据成员包括左下角和右上角坐标,定义的成员函数包括必要的构造函数、输入坐标的函数,以及计算并输出矩形面积的函数。要求使用提示中给出的测试函数并不得改动。

Input

四个数,分别表示矩形左下角和右上角顶点的坐标,如输入3.7 0.4 6.5 4.9,代表左下角坐标为(3.7, 0.4),右上角坐标为(6.5, 4.9)。

bubuko.com,布布扣

Output

输出一共有3行(请参考提示(hint)中的main函数):
第一行:由输入的坐标确定的矩形对象p1的面积
第二行:由对象复制得到的矩形对象p2的面积
第三行:直接初始化得到的矩形对象p3的面积

Sample Input

3.7 0.4 6.5 4.9

Sample Output

12.6
12.6
10
#include<iostream>
using namespace std;
class Rectangle
{
private:
	double x1,x2,y1,y2,n;
public:
Rectangle()
{ }
Rectangle(double q1,double m1,double q2,double m2):x1(q1),x2(q2),y1(m1),y2(m2)
{
	
}
void input()
	{
		cin>>x1>>y1>>x2>>y2;
	}
void output()
{
	n=(x1-x2)*(y1-y2);
	cout<<n<<endl;
}
};


int main()

{

    Rectangle p1;

    p1.input();

    p1.output();

    Rectangle p2(p1);

    p2.output();

    Rectangle p3(1,1,6,3);

    p3.output();

    return 0;

}


矩形类定义,布布扣,bubuko.com

矩形类定义

标签:des   class   blog   code   http   tar   

原文地址:http://blog.csdn.net/rememberautumn/article/details/33730661

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!