码迷,mamicode.com
首页 > 其他好文 > 详细

poj2184 Cow Exhibition p-01背包的灵活运用

时间:2014-06-25 07:20:08      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:p-01背包的灵活运用   poj   

转载请注明出处:http://blog.csdn.net/u012860063

Description

"Fat and docile, big and dumb, they look so stupid, they aren‘t much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si‘s and, likewise, the total funness TF of the group is the sum of the Fi‘s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source


题意:要求从N头牛中选择若干头牛去参加比赛,假设这若干头牛的智商之和为sumS,幽默度之和为sumF现要求在所有选择中,在使得sumS>=0&&sumF>=0的基础上,使得sumS+sumF最大并输出其值.
思路:其实这道题和普通0-1背包差不多,只是要转换下思想,就是在求fun[j]中可以达到的最大smart。
我们设智商属性为费用,幽默感属性为价值,问题转换为求费用大于和等于0时的费用、价值总和

代码+解释如下:
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdlib>
#include <climits>
#include <ctype.h>
#include <queue>
#include <stack>
#include <vector>
#include <deque>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
#define INF 0x3fffffff
int MAX(int a,int b)
{
	if( a > b)
		return a;
	return b;
}
int main()
{
	int s[147],f[147],dp[200047];
	int N,i,j;
	while(~scanf("%d",&N))
	{
		for(i = 0 ; i <= 200000 ; i++)
		{
			dp[i] =-INF;
		}
		for(i = 1 ; i <= N ; i++)
		{
			scanf("%d%d",&s[i],&f[i]);
		}
		dp[100000] = 0;//初始化dp[100000]相当于“dp[0]”也就是智力和为零的时候
		for(i = 1 ; i <= N ; i++)
		{
			if(s[i] < 0 && f[i] < 0)
				continue;
			if(s[i] > 0)//如果s[i]为正数,那么我们就从大的往小的方向进行背包
			{
				for(j = 200000 ; j >= s[i] ; j--)//100000以上是智力和为正的时候
				{  
					if(dp[j-s[i]] > -INF)
					{
						dp[j]=MAX(dp[j],dp[j-s[i]]+f[i]);
					}
				}
			}
			else//如果s[i]为负数,那么我们就从大的往小的方向进行背包
			{
				for(j = s[i] ; j <= 200000+s[i] ; j++)//100000一下是当智力和为负的时候
				{
					if(dp[j-s[i]] > -INF)
					{
						dp[j]=MAX(dp[j],dp[j-s[i]]+f[i]);
					}
				}
			}
		}
		int ans=-INF;
		for(i = 100000 ; i <= 200000 ; i++)//只在智力和为正的区间查找智力和幽默值的和最大的
		{
			if(dp[i]>=0)
			{
				ans=MAX(ans,dp[i]+i-100000);
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


poj2184 Cow Exhibition p-01背包的灵活运用,布布扣,bubuko.com

poj2184 Cow Exhibition p-01背包的灵活运用

标签:p-01背包的灵活运用   poj   

原文地址:http://blog.csdn.net/u012860063/article/details/34140981

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!