码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3617 Best Cow Line 贪心

时间:2014-06-25 08:46:12      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   code   http   

Best Cow Line
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9116   Accepted: 2762

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows‘ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he‘s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial (‘A‘..‘Z‘) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A‘..‘Z‘) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source


题解

题目要求是,有两种操作,从头取出一个字符,或者从尾取出一个字符,加到一个新的字符串末端,然后保证这个字符串是所有可能生成的字符串中,字典序排列最小的那个。依旧是贪心的想法,谁小我取谁即可。特殊判断两者相同的。一旦两者相同,那么就接着判断下一种,直到找到更小的为止。

另外需要注意两点,题目的输入很变态,要一个字母一行的输入,所以用cin或者用scanf(" %c", &ch)。cin不多说了,除了慢点其他没啥缺点。scanf中为何要加上一个空格呢?因为在格式串中,空格的意思是匹配输入中的所有换行、TAB、空格,所以加上一个空格,就可以屏蔽掉在输入中的所有的不愉快的因素了。

还有一个就是输出,切记,每80个字符输出一行。所以不要犯多输出一行空行的错误。

代码示例

/**============================================================================
#       COPYRIGHT NOTICE
#       Copyright (c) 2014 All rights reserved
#       ----Stay Hungry Stay Foolish----
#
#       @author       :Shen
#       @name         :POJ 3617
#       @file         :G:\My Source Code\【ACM】训练\0624 - 基础\poj3617.cpp
#       @date         :2014/06/24 13:46
#       @algorithm    :Greedy
============================================================================**/

//#pragma GCC optimize ("O2")
//#pragma comment(linker, "/STACK:1024000000,1024000000")

#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <algorithm>
using namespace std;
template<class T>inline bool updateMin(T& a, T b){ return a > b ? a = b, 1: 0; }
template<class T>inline bool updateMax(T& a, T b){ return a < b ? a = b, 1: 0; }

typedef long long int64;

int n;
char t[2005], s[2005];

void solve()
{
    for (int i = 0; i < n; i++)
        scanf(" %c", &t[i]);
    int i = 0, j = n - 1;
    for (int k = 0; k < n; k++)
    {
        if (t[i] > t[j]) s[k] = t[j--];
        else if (t[i] < t[j]) s[k] = t[i++];
        else
        {
            int it = i, jt = j;
            bool flag = 0;
            while (t[it] == t[jt] && it <= jt) it++, jt--;
            flag = (t[it] < t[jt]);
            if (flag) s[k] = t[i++];
            else s[k] = t[j--];
        }
    }
    for (int i = 0; i < n; i++)
    {
        printf("%c", s[i]);
        if (i % 80 == 79) printf("\n");
    }
    if (n % 80) printf("\n");
}

int main()
{
    while (~scanf("%d", &n)) solve();
    return 0;
}


POJ 3617 Best Cow Line 贪心,布布扣,bubuko.com

POJ 3617 Best Cow Line 贪心

标签:des   style   class   blog   code   http   

原文地址:http://blog.csdn.net/polossk/article/details/34116627

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!