码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3069 Saruman's Army 贪心

时间:2014-06-25 07:15:39      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   code   http   

Saruman‘s Army
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3612   Accepted: 1846

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = ?1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source



题解

题目抽象出来就是用一个半径为R的圆去覆盖一条直线上的点。每个园内必须有至少一个被标记的点。问最少需要标记多少个点。

贪心去处理就行了,给从左边开始,在园内的最右边的点加上标记即可。

代码示例

/**============================================================================
#       COPYRIGHT NOTICE
#       Copyright (c) 2014 All rights reserved
#       ----Stay Hungry Stay Foolish----
#
#       @author       :Shen
#       @name         :POJ 3069
#       @file         :G:\My Source Code\【ACM】训练\0624 - 基础\poj3069.cpp
#       @date         :2014-06-24 14:33
#       @algorithm    :Greedy
============================================================================**/

//#pragma GCC optimize ("O2")
//#pragma comment(linker, "/STACK:1024000000,1024000000")

#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <algorithm>
using namespace std;
template<class T>inline bool updateMin(T& a, T b){ return a > b ? a = b, 1: 0; }
template<class T>inline bool updateMax(T& a, T b){ return a < b ? a = b, 1: 0; }

typedef long long int64;

int r, n;
int x[1005];

void solve()
{
    for (int i = 0; i < n; i++)
        scanf("%d", &x[i]);
    sort(x, x + n);
    int i = 0, ans = 0;
    while (i < n)
    {
        int s = x[i++];
        while (i < n && x[i] <= s + r) i++;
        int p = x[i - 1];
        while (i < n && x[i] <= p + r) i++;
        ans++;
    }
    printf("%d\n", ans);
}

int main()
{
    while (scanf("%d%d", &r, &n))
    {
        if (r == -1 && n == -1) break;
        else solve();
    }
    return 0;
}

POJ 3069 Saruman's Army 贪心,布布扣,bubuko.com

POJ 3069 Saruman's Army 贪心

标签:des   style   class   blog   code   http   

原文地址:http://blog.csdn.net/polossk/article/details/34116081

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!