码迷,mamicode.com
首页 > 其他好文 > 详细

poj3903 Stock Exchange最大上升子序列

时间:2014-06-26 10:25:10      阅读:660      评论:0      收藏:0      [点我收藏+]

标签:stl   动态规划   

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://poj.org/problem?id=3903

Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer). 
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend. 
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6 
5 2 1 4 5 3 
3  
1 1 1 
4 
4 3 2 1

Sample Output

3 
1 
1

第一种:http://blog.csdn.net/u012860063/article/details/34086819

代码如下:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int a[100047],dp[100047],n;

int bin(int size,int k)
{
    int l = 1,r = size;
    while(l<=r)
    {
        int mid = (l+r)/2;
        if(k>dp[mid])
            l = mid+1;
        else
            r = mid-1;
    }
    return l;
}

int LIS(int *a)
{
    int i,j,ans=1;
    dp[1] = a[1];
    for(i = 2; i<=n; i++)
    {
        if(a[i]<=dp[1])
            j = 1;
        else if(a[i]>dp[ans])
            j = ++ans;
        else
            j = bin(ans,a[i]);
        dp[j] = a[i];
    }
    return ans;
}
int main()
{
	int i;
	while(~scanf("%d",&n))
	{
		for(i = 1; i <= n; i++)
		{
			scanf("%d",&a[i]);
		}
		int ans = LIS(a);
		printf("%d\n",ans);
	}
	return 0;
}

第二种使用了:lower_bound

代码如下:

#include<cstdio>
#include<algorithm>
using namespace std;
#define INF 0x3fffffff

int a[100047],dp[100047];

int main()
{
	int t,i;
	while(scanf("%d",&t)!=EOF)
	{
		for(i = 0; i <= t; i++)
			dp[i]=INF;
		for(i = 0; i < t; i++)
		{
			scanf("%d",&a[i]);
		}
		for(i = 0; i < t; i++)
		{
			*lower_bound(dp,dp+t,a[i])=a[i];
		}
		printf("%d\n",lower_bound(dp,dp+t,INF)-dp);
	}
	return 0;
}

附上解释的图片一张:

bubuko.com,布布扣

poj3903 Stock Exchange最大上升子序列,布布扣,bubuko.com

poj3903 Stock Exchange最大上升子序列

标签:stl   动态规划   

原文地址:http://blog.csdn.net/u012860063/article/details/34495159

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!