码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 2602 Bone Collector

时间:2014-06-26 11:26:15      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   code   java   

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27413    Accepted Submission(s): 11154


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
bubuko.com,布布扣

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14

01背包。


AC代码例如以下:


#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int t,n,v;
    int i,j;
    int a[1005],b[1005],dp[1005];
    cin>>t;
    while(t--)
    {
        cin>>n>>v;
        for(i=1;i<=n;i++)
            cin>>a[i];
        for(i=1;i<=n;i++)
            cin>>b[i];
        memset(dp,0,sizeof dp);
        for(i=1;i<=n;i++)
            for(j=v;j>=b[i];j--)
            dp[j]=max(dp[j-b[i]]+a[i],dp[j]);
            cout<<dp[v]<<endl;
    }

    return 0;
}


杭电 2602 Bone Collector,布布扣,bubuko.com

杭电 2602 Bone Collector

标签:des   style   class   blog   code   java   

原文地址:http://www.cnblogs.com/hrhguanli/p/3809349.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!