码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3332 Strange Country II

时间:2014-06-26 12:12:01      阅读:266      评论:0      收藏:0      [点我收藏+]

标签:dfs回溯

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3332

Description

You want to visit a strange country. There are n cities in the country. Cities are numbered from 1 to n. The unique way to travel in the country is taking planes. Strangely, in this strange country, for every two cities A and B, there is a flight from A to B or from B to A, but not both. You can start at any city and you can finish your visit in any city you want. You want to visit each city exactly once. Is it possible?

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 100) indicating the number of test cases. Then T test cases follow. Each test case starts with a line containing an integer n (0 < n <= 100), which is the number of cities. Each of the next n * (n - 1) / 2 lines contains 2 numbers AB (0 < AB <= nA != B), meaning that there is a flight from city A to city B.

Output

For each test case:

  • If you can visit each city exactly once, output the possible visiting order in a single line please. Separate the city numbers by spaces. If there are more than one orders, you can output any one.
  • Otherwise, output "Impossible" (without quotes) in a single line.

Sample Input

3
1
2
1 2
3
1 2
1 3
2 3

Sample Output

1
1 2
1 2 3


先说说题目的意思吧:


某人到了一个陌生城市,这个城市的特点就是:每两个城市之间都有飞机直接到达,但是不一定的双向的,也就是A - > B != B - > A,


给出城市的数量n,以及n * (n - 1) / 2  条城市 x  到 城市 y 的路,(表示x 到 y 有飞机),问你是不是可以每个城市都经过并且只经过一次


可以的话,一次输出经过的城市,否则输出Impossible




分析:很显然,先建立一个邻接矩阵map[A][B], 表示A 到B之间路线的情况,if(A - > B),map[A][B] = 1;  else map[A][B] = 0;


           然后用num[N] 记录走过了的城市,关键是怎么来表示呢?  放在dfs里面,表示这之间确实有路,那么就可以记录了


          用vis[N]查询是不是访问过了,这个很关键


         t的作用是判断是不是所有的城市都去过了,没去过一个城市,t做一次减法。。

详见代码:
#include <cstdio>
#include<cstring>
int map[105][105];
int num[105] ;
bool vis[105];
int flag ;
int t, n;
void dfs(int v)
{
	num[t++] = v;       //记录节点
	if(t == n)          //已找到,退出
	{ 
		flag = 1;
		return;
	}
	for(int u = 1; u <= n; u++) 
	{
		if(!vis[u] && map[v][u] == 1) //未标记过,且有路
		{
			vis[u] = true;
			dfs(u);                //继续寻找
			
			if(flag == 1)         //如果找到就退出
				return;
			t--;                 //注意,未找到就减一
			vis[u] = false;      //回溯到原来的状态
		}
	}
}
int main()
{
	int T,a, b, i;
	scanf("%d", &T);
	while(T--) 
	{
		scanf("%d", &n);
		memset(map,0,sizeof(map));
		memset(vis,0,sizeof(vis));
		for(i = 0 ; i < n * (n - 1) / 2 ; i++) 
		{
			scanf("%d %d", &a, &b) ;
			map[a][b] = 1;
		}
		flag = 0;
		for(i = 1; i <= n; i++) 
		{
			vis[i] = true;
			t = 0;                //初始为零
			dfs(i);
			if(flag)              //如果找到就退出
				break;
			vis[i] = false;       //回溯到原来的状态
		}
		if(flag)                  //如果存在
		{
			for(i = 0; i < n; i ++)
			{
				if(i == 0)
					printf("%d", num[i]);
				else
					printf(" %d", num[i]);
			}
			printf("\n");
		}
		else 
			printf("Impossible\n");
	}
	return 0;
}
/*
5
5
1 3
3 5
2 5
2 4
1 3
1 3
1 3
1 3
1 3
1 3
6
1 2
1 6
1 4
5 6
5 4
3 4
3 2
1 2
1 2
1 2
1 2
1 2
1 2
1 2
1 2
*/



zoj 3332 Strange Country II,布布扣,bubuko.com

zoj 3332 Strange Country II

标签:dfs回溯

原文地址:http://blog.csdn.net/u012860063/article/details/34809273

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!