码迷,mamicode.com
首页 > 其他好文 > 详细

poj3253 Fence Repair STL优先队列

时间:2014-06-26 11:40:26      阅读:242      评论:0      收藏:0      [点我收藏+]

标签:stl   优先队列   

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://poj.org/problem?id=3253

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn‘t own a saw with which to cut the wood, so he mosies over to Farmer Don‘s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn‘t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source

大致题意:

有一个农夫要把一个木板钜成几块给定长度的小木板,每次锯都要收取一定费用,这个费用就是当前锯的这个木版的长度

给定各个要求的小木板的长度,及小木板的个数n,求最小费用

 

提示:

3

5 8 5为例:

先从无限长的木板上锯下长度为 21 的木板,花费 21

再从长度为21的木板上锯下长度为5的木板,花费5

再从长度为16的木板上锯下长度为8的木板,花费8

总花费 = 21+5+8 =34

 

解题思路:

利用Huffman思想,要使总费用最小,那么每次只选取最小长度的两块木板相加,再把这些“和”累加到总费用中即可

本题虽然利用了Huffman思想,但是直接用HuffmanTree做会超时,可以用优先队列做


代码如下:


/*STL 优先队列*/
#include <cstdio>
#include <queue>
#include <vector>
#include <iostream>
using namespace std;
int main()
{
	int n;//需要切割的木板个数
	__int64 temp,a,b,mincost;
	while(~scanf("%d",&n))
	{
		//定义从小到大的优先队列,可将greater改为less,即为从大到小
		priority_queue<int, vector<int>, greater<int> > Q;
		
		while(!Q.empty())//清空队列
			Q.pop();
		
		for(int i = 1; i <= n; i++)
		{
			scanf("%I64d",&temp);
			Q.push(temp);//输入要求的木板长度(费用)并入队
		}
		
		mincost = 0;//最小费用初始为零
		
		while(Q.size() > 1)//当队列中小于等于一个元素时跳出
		{
			a = Q.top();//得到队首元素的值,并使其出队
			Q.pop();
			b = Q.top();//两次取队首,即得到最小的两个值
			Q.pop();
			Q.push(a+b);//把两个最小元素的和入队
			mincost +=a+b;
		}
		printf("%I64d\n",mincost);
	}
	return 0;
}


poj3253 Fence Repair STL优先队列,布布扣,bubuko.com

poj3253 Fence Repair STL优先队列

标签:stl   优先队列   

原文地址:http://blog.csdn.net/u012860063/article/details/34805369

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!