码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1081 & poj 1050 To The Max(最大和的子矩阵)

时间:2014-06-28 08:16:30      阅读:223      评论:0      收藏:0      [点我收藏+]

标签:hdu   poj   dp   

转载请注明出处:http://blog.csdn.net/u012860063


Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source


题意:给你一个N*N的矩阵,求其中和最大的子矩阵的值!

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
	int i, j, k, t;
	int a, sum, max, N, m[147][147];
	while(~scanf("%d",&N))
	{
		memset(m,0,sizeof(m));
		for(i = 1; i <= N; i++)
		{
			for(j = 1; j <= N; j++)
			{
				scanf("%d",&a);
				m[i][j]+=m[i][j-1]+a;//表示第i行前j个数之和 
			}
		}
		max = -128;
		for(i = 1; i <= N; i++)//起始列 
		{
			for(j = i; j <= N; j++)//终止列 
			{
				sum = 0;
				for(k = 1; k <= N; k++)//对每一行进行搜索 
				{
					if(sum < 0)
					sum = 0;
					sum+=m[k][j]-m[k][i-1];
					//m[k][j]-m[k][i-1]表示第k行第i列之间的数 
					if(sum > max)
					max = sum;
				}
			}
		}
		printf("%d\n",max);
	}
	return 0;
}


hdu 1081 & poj 1050 To The Max(最大和的子矩阵),布布扣,bubuko.com

hdu 1081 & poj 1050 To The Max(最大和的子矩阵)

标签:hdu   poj   dp   

原文地址:http://blog.csdn.net/u012860063/article/details/35273233

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!