码迷,mamicode.com
首页 > 其他好文 > 详细

挑战题之排列生成

时间:2014-05-05 22:25:33      阅读:294      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   color   

挑战题之排列生成

 

Time Limit:   2000MS       Memory Limit:   65535KB
Submissions:   435       Accepted:   170

 

Description

一自然数N,设N为3,则关于N的字典序排列为123,132,213,231,312,321。对于一个自然数N(1<= N <= 9 ) , 你要做的便是生成它的字典序排列。

Input

第一行为自然数N。

Output

输出对应于N的字典序排列,每个排列占一行。

Sample Input

3

Sample Output

123
132
213
231
312
321
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#include<iostream>
#include <cstdio>
using namespace std;
int s[10];
int s1[10];
int vis[10] = {0};
void dfs(int l,int n )
{
    int i;
    if(l>=n)
    {
        for(i= 0;i<n;i++)
            printf("%d",s1[i]);
            printf("\n");
    }
    for(i=0;i<n;i++)
    {
        if(!vis[i])
        {
            vis[i] = 1;
        s1[l] = s[i];
        dfs(l+1,n);
        vis[i] = 0;
        }
    }
 
}
int main()
{
    int num;
    cin>>num;
    for(int i=0;i<num;i++)
        s[i] = i+1;
    dfs (0, num);
    return 0;
}

  

挑战题之排列生成,布布扣,bubuko.com

挑战题之排列生成

标签:des   style   blog   class   code   color   

原文地址:http://www.cnblogs.com/locojyw/p/3704851.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!