码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1115 Lifting the Stone(几何,求多边形重心模板题)

时间:2014-06-30 10:12:14      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:几何篇   hdu   

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1115



Lifting the Stone


Problem Description
There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.
 
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.
 
Output
Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.
 
Sample Input
2 4 5 0 0 5 -5 0 0 -5 4 1 1 11 1 11 11 1 11
 

Sample Output
0.00 0.00 6.00 6.00

题意:就是给你一个多边行的点的坐标,求此多边形的重心。

一道求多边形重心的模板题!

代码如下:

//求多边形中心(采用吉林大学模板)
#include <cstdio>
#include <cmath>
#include <cstring>

struct point 
{
	double x, y; 
}PP[1000047];

point bcenter(point pnt[], int n)
{
	point p, s;
	double tp, area = 0, tpx = 0, tpy = 0;
	p.x = pnt[0].x; 
	p.y = pnt[0].y;
	for (int i = 1; i <= n; ++i) 
	{ // point: 0 ~ n-1
		s.x = pnt[(i == n) ? 0 : i].x;
		s.y = pnt[(i == n) ? 0 : i].y;
		tp = (p.x * s.y - s.x * p.y);
		area += tp / 2;
		tpx += (p.x + s.x) * tp;
		tpy += (p.y + s.y) * tp;
		p.x = s.x; p.y = s.y;
	}
	s.x = tpx / (6 * area); s.y = tpy / (6 * area);
	return s;
}

int main()
{
	int N, t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&N);
		for(int i = 0; i < N; i++)
		{
			scanf("%lf%lf",&PP[i].x,&PP[i].y);
		}
		point ss = bcenter(PP,N);
		printf("%.2lf %.2lf\n",ss.x ,ss.y);
	}
	return 0;
}


模版如下:

struct point 
{
	double x, y; 
};

point bcenter(point pnt[], int n)
{
	point p, s;
	double tp, area = 0, tpx = 0, tpy = 0;
	p.x = pnt[0].x; 
	p.y = pnt[0].y;
	for (int i = 1; i <= n; ++i) 
	{ // point: 0 ~ n-1
		s.x = pnt[(i == n) ? 0 : i].x;
		s.y = pnt[(i == n) ? 0 : i].y;
		tp = (p.x * s.y - s.x * p.y);
		area += tp / 2;
		tpx += (p.x + s.x) * tp;
		tpy += (p.y + s.y) * tp;
		p.x = s.x; p.y = s.y;
	}
	s.x = tpx / (6 * area); s.y = tpy / (6 * area);
	return s;
}



hdu1115 Lifting the Stone(几何,求多边形重心模板题),布布扣,bubuko.com

hdu1115 Lifting the Stone(几何,求多边形重心模板题)

标签:几何篇   hdu   

原文地址:http://blog.csdn.net/u012860063/article/details/35549711

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!