码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2317Nasty Hacks

时间:2015-06-06 19:21:14      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use
to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

 

 

Input
The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.
 

 

Output
Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.
 

 

Sample Input
3 0 100 70 100 130 30 -100 -70 40
 

 

Sample Output
advertise does not matter do not advertise
 

 

Source
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>

using namespace std;

int main()
{
    int n;
    cin>>n;
    int i,j,k;
    for(i = 0;i<n;i++)
    {
        int a,b,c;
        cin>>a>>b>>c;
        if(a>b-c)
        {
            cout<<"do not advertise"<<endl;
        }
        else if(a == b-c)
        {
            cout<<"does not matter"<<endl;
        }
        else
        {
            cout<<"advertise"<<endl;
        }
    }
    return 0;
}

 

hdu2317Nasty Hacks

标签:

原文地址:http://www.cnblogs.com/wos1239/p/4557011.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!