码迷,mamicode.com
首页 > 其他好文 > 详细

poj1488 字符串处理

时间:2014-05-03 15:40:11      阅读:296      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   ext   

TEX Quotes
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 8505   Accepted: 4460

Description

TEX is a typesetting language developed by Donald Knuth. It takes source text together with a few typesetting instructions and produces, one hopes, a beautiful document. Beautiful documents use double-left-quote and double-right-quote to delimit quotations, rather than the mundane " which is what is provided by most keyboards. Keyboards typically do not have an oriented double-quote, but they do have a left-single-quote ` and a right-single-quote ‘. Check your keyboard now to locate the left-single-quote key ` (sometimes called the "backquote key") and the right-single-quote key ‘ (sometimes called the "apostrophe" or just "quote"). Be careful not to confuse the left-single-quote ` with the "backslash" key \. TEX lets the user type two left-single-quotes `` to create a left-double-quote and two right-single-quotes ‘‘ to create a right-double-quote. Most typists, however, are accustomed to delimiting their quotations with the un-oriented double-quote ". 

If the source contained 
"To be or not to be," quoth the bard, "that is the question." 
then the typeset document produced by TEX would not contain the desired form: "To be or not to be," quoth the bard, "that is the question." In order to produce the desired form, the source file must contain the sequence: 
``To be or not to be,‘‘ quoth the bard, ``that is the question.‘‘ 
You are to write a program which converts text containing double-quote (") characters into text that is identical except that double-quotes have been replaced by the two-character sequences required by TEX for delimiting quotations with oriented double-quotes. The double-quote (") characters should be replaced appropriately by either `` if the " opens a quotation and by ‘‘ if the " closes a quotation. Notice that the question of nested quotations does not arise: The first " must be replaced by ``, the next by ‘‘, the next by ``, the next by ‘‘, the next by ``, the next by ‘‘, and so on. 

Input

Input will consist of several lines of text containing an even number of double-quote (") characters. Input is ended with an end-of-file character.

Output

The text must be output exactly as it was input except that: 

  • the first " in each pair is replaced by two ` characters: `` and 
  • the second " in each pair is replaced by two ‘ characters: ‘‘. 

Sample Input

"To be or not to be," quoth the Bard, "that
is the question".
The programming contestant replied: "I must disagree.
To `C‘ or not to `C‘, that is The Question!"

Sample Output

``To be or not to be,‘‘ quoth the Bard, ``that
is the question‘‘.
The programming contestant replied: ``I must disagree.
To `C‘ or not to `C‘, that is The Question!‘‘

题目说那么多,重点其实就在双引号的处理。题目没说输入的每行有多长~~反正用数组貌似不行。


#include<stdio.h>
#include<string.h>
int main(){
	char c;
	int j=0;
	while(scanf("%c",&c)!=EOF){	
		  if(c==‘"‘&&j==0){
		  	putchar(‘`‘);
		  	putchar(‘`‘);
		  	j++;
		  }
		  else if(c==‘"‘&&j==1){
		  	putchar(‘\‘‘);
		  	putchar(‘\‘‘);
		  	j=0;
		  }
		  else putchar(c);
	}
	return 0;
}

poj1488 字符串处理,布布扣,bubuko.com

poj1488 字符串处理

标签:des   style   blog   class   code   ext   

原文地址:http://blog.csdn.net/lindonglian/article/details/24885337

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!