码迷,mamicode.com
首页 > 其他好文 > 详细

HDU--2114

时间:2015-06-08 17:18:05      阅读:80      评论:0      收藏:0      [点我收藏+]

标签:hdu

Calculate S(n)

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8905    Accepted Submission(s): 3257


Problem Description
Calculate S(n).

S(n)=13+23 +33 +......+n3 .
 

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.
 

Output
For each case, output the last four dights of S(N) in one line.
 

Sample Input
1 2
 

Sample Output
0001 0009
 

Author
天邪

#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
	long long int n;
	while (cin >> n)
	{
		long long int result;
		result = ((n * (n+1) / 2) %10000) * ((n * (n+1) /2) %10000) %10000;
		printf("%04lld\n",result);
	}
	return 0;
}


HDU--2114

标签:hdu

原文地址:http://blog.csdn.net/xiaotan1314/article/details/46415153

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!