码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3123GCC

时间:2015-06-09 21:39:38      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
 

 

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
 

 

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
 

 

Sample Input
1 10 861017
 

 

Sample Output
593846
 

 

Source
 
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>

using namespace std;

char s[110000];

int main()
{
    long long t,n,md,a,i,sum,l;
    cin>>t;
    while(t--)
    {
        cin>>s>>md;
        l = strlen(s);
        n = 0;
        if(l>7)n = md;
        else
            for(i = 0;i<l;i++)
                n = n*10+s[i]-0;
        sum = a = 1;
        for(i = 1;i<=n;i++)
        {
            a = (a*i)%md;
            sum = (sum+a)%md;
        }
        sum%=md;
        cout<<sum<<endl;
    }
    return 0;
}

 

hdu3123GCC

标签:

原文地址:http://www.cnblogs.com/wos1239/p/4564473.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!