码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1328 IBM Minus One

时间:2015-06-10 22:24:04      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:

IBM Minus One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4462    Accepted Submission(s): 2337

Problem Description

You may have heard of the book ‘2001 - A Space Odyssey‘ by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don‘t tell you how the story ends, in case you want to read the book for yourself :-)

After the movie was released and became very popular, there was some discussion as to what the name ‘HAL‘ actually meant. Some thought that it might be an abbreviation for ‘Heuristic ALgorithm‘. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.
 

Input

The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.
 
Output
For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing ‘Z‘ by ‘A‘.

Print a blank line after each test case.
 
Sample Input
2 HAL SWERC
 

Sample Output

String #1 IBM String #2 TXFSD
 

Source

 
技术分享
#include<iostream>
#include<string>
using namespace std;

int main(void)
{
    int n,j=1;
    string str;

    cin>>n;
    while(n--)
    {
        cin>>str;
        for(int i=0;i<str.size();i++)
        {
            if(str[i]==Z)
                str[i] = A;    //注意一下就行
            else
                str[i] = str[i]+1;
        }
        cout<<"String #"<<j<<endl<<str<<endl<<endl;
        j++;
    }

    return 0;
}
View Code

 

HDU 1328 IBM Minus One

标签:

原文地址:http://www.cnblogs.com/samjustin/p/4567263.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!