码迷,mamicode.com
首页 > 其他好文 > 详细

XTU 1207 Welcome to XTCPC (模拟)

时间:2015-06-13 11:22:43      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:

Welcome to XTCPC

Accepted : 190   Submit : 381
Time Limit : 1000 MS   Memory Limit : 65536 KB

Problem Description

Welcome to XTCPC!XTCPC start today, you are going to choose a slogan to celebrate it, many people give you some candidate string about the slogan, but the slogan itself must have something relavant to XTCPC, a string is considered relevant to XTCPC if it become XTCPC after deleting some characters in it. For example, XTCPC, XTCCPCC, OIUXKKJATSADCASPHHC is relevant, XX,FF,GG,CPCXT,XTCP is not.Now you have to write a program to judge whether a string is relevant to XTCPC.

Input

First line an integer t(t≤100), the number of testcases.For each case, there is a string(length≤100, all are uppercase characters).

Output

For each case, output case number first, then "Yes" if the string is relevant, "No" if the string is not relevant. Quote for clarify.

Sample Input

3
XTCPC
CCC
XXXXTTTTCCCCPPPCCC


Sample Output

Case 1: Yes
Case 2: No
Case 3: Yes



Source

XTU OnlineJudge




解析:查看数组中是否存在有序的“XTCPC“即可。




AC代码:

#include <bits/stdc++.h>
using namespace std;

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk

    int t;
    int f1, f2, f3, f4, f5;
    string s;
    scanf("%d", &t);
    for(int i=1; i<=t; i++){
        f1 = f2 = f3 = f4 = f5 = 0;
        cin>>s;
        int len = s.size();
        for(int j=0; j<len; j++){
            if(f1){
                if(f2){
                    if(f3){
                        if(f4){
                            if(s[j] == 'C'){
                                f5 = 1;
                                break;
                            }
                        }
                        else if(s[j] == 'P') f4 = 1;
                    }
                    else if(s[j] == 'C') f3 = 1;
                }
                else if(s[j] == 'T') f2 = 1;
            }
            else if(s[j] == 'X') f1 = 1;
        }
        printf("Case %d: %s\n", i, f5 ? "Yes" : "No");
    }
    return 0;
}


XTU 1207 Welcome to XTCPC (模拟)

标签:

原文地址:http://blog.csdn.net/u013446688/article/details/46480891

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!