码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1009 贪心

时间:2015-06-13 17:14:31      阅读:105      评论:0      收藏:0      [点我收藏+]

标签:

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51935    Accepted Submission(s): 17434


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
13.333 31.500
 

Author
CHEN, Yue
 

Source
按照性价比最高的排序,然后求和就行,如果m小于F[i],那么只取这个的a%,而a%=m/F[i].
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct point
{
	double x,y;
}a[2000];
bool cmp(point xx,point yy)
{
	if((xx.x/xx.y)>(yy.x/yy.y))
		return true;
	return false;
}
int main()
{
	int n;
	double m;
	while(~scanf("%lf%d",&m,&n))
	{
		memset(a,0,sizeof(a));
		if(m==-1&&n==-1)
			break;
		for(int i=0;i<n;i++)
		{
			scanf("%lf%lf",&a[i].x,&a[i].y);
		}
		sort(a,a+n,cmp);
		double sum=0;
		for(int i=0;i<n;i++)
		{
			if(a[i].y<=m)
			{
				m-=a[i].y;
				sum+=a[i].x;
			}
			else if(m>0)
			{
				sum+=a[i].x*(m/a[i].y);
				m-=a[i].x*(m/a[i].y);
			}
		}
		printf("%.3lf\n",sum);
	}
	return 0;
}

hdu 1009 贪心

标签:

原文地址:http://blog.csdn.net/qq_24489717/article/details/46482899

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!