码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1979 Red and Black

时间:2015-06-14 15:02:56      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 25228   Accepted: 13605

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

#include<stdio.h>
#include<string.h>
#define MAX 25
char str[MAX][MAX];
int n,m,sum;
void dfs(int x,int y)
{
	int i,j;
	if(0<=x&&x<m&&0<=y&&y<n&&str[x][y]==‘.‘)
	{
		str[x][y]=‘#‘;//将判断过的点封死(即不能再在上边行走) 
		sum++;     //当当前点是"."时满足条件 sum自加1 
		dfs(x-1,y);//搜索当前点下部 
		dfs(x+1,y);//搜索当前点上部 
		dfs(x,y-1);//搜索当前点左部 
		dfs(x,y+1);//搜索当前点右部 
	}
	return ;
}
int main()
{
	int j,i,s;
	while(scanf("%d%d",&n,&m)&&n!=0&&m!=0)
	{
		for(i=0;i<m;i++)
		scanf("%s",str[i]);
		sum=0;
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				if(str[i][j]==‘@‘)
				{
					str[i][j]=‘.‘;
					dfs(i,j);
				}
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

  




poj 1979 Red and Black

标签:

原文地址:http://www.cnblogs.com/tonghao/p/4575064.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!