码迷,mamicode.com
首页 > 其他好文 > 详细

HDU Humble Numbers (dp)

时间:2015-06-15 09:17:58      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:c++   编程   acm   algorithm   算法   

Humble Numbers

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 8   Accepted Submission(s) : 4

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

Source

University of Ulm Local Contest 1996 
AC代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int main(){
    int n;
    char s1,s2;
    int dp[6000],i;
    dp[1]=1;
    i=2;
    int two=1,three=1,five=1,seven=1,t1,t2;
    while(i<=5842){
        dp[i]=min((t1=min(2*dp[two],3*dp[three])),(t2=min(5*dp[five],dp[seven]*7)));
        if(dp[i]==dp[two]*2)two++;
        if(dp[i]==dp[three]*3)three++;
        if(dp[i]==dp[five]*5)five++;
        if(dp[i]==dp[seven]*7)seven++;
        i++;
    }
    while(cin>>n&&n){
        if(n%10==1&&n%100!=11)s1='s',s2='t';
        else if(n%10==2&&n%100!=12)s1='n',s2='d';
        else if(n%10==3&&n%100!=13)s1='r',s2='d';
        else s1='t',s2='h';
        printf("The %d%c%c humble number is %d.\n",n,s1,s2,dp[n]);
    }
    return 0;
}


HDU Humble Numbers (dp)

标签:c++   编程   acm   algorithm   算法   

原文地址:http://blog.csdn.net/zp___waj/article/details/46495267

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!