码迷,mamicode.com
首页 > 其他好文 > 详细

HDU Common Subsequence (dp)

时间:2015-06-15 09:19:26      阅读:94      评论:0      收藏:0      [点我收藏+]

标签:c++   算法   编程   acm   algorithm   

Common Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 7

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003 
AC代码:
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
int main(){
    string s1,s2;
    int dp[500][500];
    int i,j,lena,lenb;
    while(cin>>s1>>s2){
        lena=s1.length();
        lenb=s2.length();
        for(i=0;i<lena;++i)dp[0][i]=0,dp[i][0]=0;
        for(i=0;i<lena;++i){
            for(j=0;j<lenb;++j){
                if(s1[i]==s2[j]){
                    dp[i+1][j+1]=dp[i][j]+1;
                }
                else{
                    dp[i+1][j+1]=max(dp[i+1][j],dp[i][j+1]);
                }
                //printf("dp[%d][%d]=%d ",i,j,dp[i][j]);
            }
           // putchar('\12');
        }
        printf("%d\n",dp[lena][lenb]);
    }
    return 0;
}


HDU Common Subsequence (dp)

标签:c++   算法   编程   acm   algorithm   

原文地址:http://blog.csdn.net/zp___waj/article/details/46495239

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!