标签:
Wooden Sticks
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 19 Accepted Submission(s) : 7
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing
a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l‘ and weight w‘ if l<=l‘ and w<=w‘. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks
in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more
spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
Source
Asia 2001, Taejon (South Korea)
AC代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
struct wooden{
int l,w;
};
wooden my[5010];
bool comp(wooden a,wooden b){
if(a.l>b.l)return 1;
else if(a.l==b.l)
return a.w>b.w;
else return 0;
}
int main(){
int t;
cin>>t;
while(t--){
int n;
cin>>n;
int i=0,j;
while(i<n)cin>>my[i++].l>>my[i].w;
sort(my,my+n,comp);
//for(i=0;i<n;++i)cout<<my[i].l<<' '<<my[i].w<<'\12';
int out=n;
for(i=1;i<n;i++)
for(j=0;j<=i-1;j++){
if(my[j].l>=my[i].l&&my[j].w>=my[i].w){
out--;
my[j].l=my[i].l;
my[j].w=my[i].w;
my[i].l=0;
my[i].w=0;
break;
}
}
// for(i=0;i<n;++i)cout<<my[i].l<<' '<<my[i].w<<'\12';
cout<<out<<'\12';
}
return 0;
}
HDU Wooden Sticks (贪心)
标签:
原文地址:http://blog.csdn.net/zp___waj/article/details/46494955