(UVa代表弗吉尼亚大学,272是其OJ上的第272题)
在TeX中,左引号是”””,右引号是““”。输入一篇包含双引号的文章,你的任务是把它转换成TeX的格式。
样例输入;
“To be or not to be,”quoth the Bard,”that is the question”.
样例输出:
”To be or not to be,“quoth the Bard,”that is the question“.
分析:
要分左右的区别,可以用一个标记flag,有空格所以不能使用是scanf(“%s”)。
#include <stdio.h>
int main()
{
int c, flag;
while((c = getchar()) != EOF){
if(c == ‘"‘){
printf("%s", flag ? "“" : "”");
flag = !flag;
}
else
printf("%c", c);
}
return 0;
}
原文地址:http://blog.csdn.net/zhou554291911/article/details/46525933