码迷,mamicode.com
首页 > 其他好文 > 详细

TeX中的引号(TeX Quote, UVa 272)

时间:2015-06-17 00:44:00      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:c   算法   考研   计算机专业   

(UVa代表弗吉尼亚大学,272是其OJ上的第272题)
在TeX中,左引号是”””,右引号是““”。输入一篇包含双引号的文章,你的任务是把它转换成TeX的格式。
样例输入;
“To be or not to be,”quoth the Bard,”that is the question”.
样例输出:
”To be or not to be,“quoth the Bard,”that is the question“.
分析:
要分左右的区别,可以用一个标记flag,有空格所以不能使用是scanf(“%s”)。

#include <stdio.h>

int main()
{
    int c, flag;
    while((c = getchar()) != EOF){
        if(c == ‘"‘){
            printf("%s", flag ? "“" : "”");
            flag = !flag;
        }
        else 
            printf("%c", c);
    }
    return 0;
}

TeX中的引号(TeX Quote, UVa 272)

标签:c   算法   考研   计算机专业   

原文地址:http://blog.csdn.net/zhou554291911/article/details/46525933

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!