码迷,mamicode.com
首页 > 其他好文 > 详细

A + B Problem II

时间:2015-06-17 15:25:27      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 256935    Accepted Submission(s): 49653


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110


#include<stdio.h>

#include<string.h>
int main()
{
char a[1000],b[1000],c[1003];
int i,j=1,p,n,n1,n2;
scanf("%d",&n);
    while(n)
{
scanf("%s %s",a,b);
n1=strlen(a)-1;
n2=strlen(b)-1;
for(i=0;n1>=0||n2>=0;i++,n1--,n2--)
{
p=0; 
if(n1>=0&&n2>=0)
c[i]=a[n1]+b[n2]-‘0‘+p;
if(n1>=0&&n2<0)
c[i]=a[n1]+p;
if(n1<0&&n2>=0)
c[i]=b[n2]+p;
if(c[i]>‘9‘)
{
c[i]=c[i]-10;
p=1;
}
}
if(p==1)printf("%d",p);
printf("Case %d:\n",j);
printf("%s + %s = ",a,b);
while(i--)
printf("%c",c[i]);
j++;
if(n!=1)
printf("\n\n");
else 
printf("\n");
n--;
}
return 0;
}

A + B Problem II

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/46533257

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!