码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3006 Dirichlet's Theorem on Arithmetic Progressions

时间:2015-06-17 18:20:14      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   poj   

分析:

这道题要先用筛法求出10^6以内的素数。。。。我竟然觉得数据太多没用这种方式,然后写出来的代码就运行超时了,呜呜……最后还是用的筛法


Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., aa + da + 2da + 3da + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet‘s Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet (1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers ad, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers ad, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346, and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset adn should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input

367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output

92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673



#include <iostream>
#include <cstring>
#include <string>
#include <cmath>

using namespace std;

const int maxn=1000010;

int i,j,k[maxn];

int main()
{
	int a,d,n,l;
	j=0;

	memset(k,0,sizeof(k));
	k[0]=k[1]=1;
	for(i=2;i<maxn/2;i++)
	{
		if(!k[i])
			for(j=i*2;j<maxn;j+=i)
				k[j]=1;
	}
/*
<span style="white-space:pre">	</span>这里,小范围测试一下,筛法有没有出错。。
	for(j=0;j<1000;j++)
		if(!k[j])
			cout<<j<<" ";
*/

	while(cin>>a>>d>>n && (a+d+n>0))
	{
		for(i=a,l=0;l<n;i+=d)
		{
			if(!k[i])
				++l;
		}
		cout<<i-d<<endl;
	}
	return 0;
}	



POJ 3006 Dirichlet's Theorem on Arithmetic Progressions

标签:acm   c++   poj   

原文地址:http://blog.csdn.net/u011694809/article/details/46536033

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!