码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2136 Vertical Histogram

时间:2015-06-17 21:41:36      阅读:112      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   poj   

分析:很久以前,在《K&R》上面碰到过这个题,只不过比这个复杂一点。。。。

也是水题,没什么说的,注意一下细节,比如输出的格式等,还有就是,一开始用的for循环,每输入一行结束后就直接打印,好郁闷^~_~^


Description

Write a program to read four lines of upper case (i.e., all CAPITAL LETTERS) text input (no more than 72 characters per line) from the input file and print a vertical histogram that shows how many times each letter (but not blanks, digits, or punctuation) appears in the all-upper-case input. Format your output exactly as shown.

Input

* Lines 1..4: Four lines of upper case text, no more than 72 characters per line.

Output

* Lines 1..??: Several lines with asterisks and spaces followed by one line with the upper-case alphabet separated by spaces. Do not print unneeded blanks at the end of any line. Do not print any leading blank lines. 

Sample Input

THE QUICK BROWN FOX JUMPED OVER THE LAZY DOG.
THIS IS AN EXAMPLE TO TEST FOR YOUR
HISTOGRAM PROGRAM.
HELLO!

Sample Output

                            *
                            *
        *                   *
        *                   *     *   *
        *                   *     *   *
*       *     *             *     *   *
*       *     * *     * *   *     * * *
*       *   * * *     * *   * *   * * * *
*     * * * * * *     * * * * *   * * * *     * *
* * * * * * * * * * * * * * * * * * * * * * * * * *
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z



#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>

using namespace std;

int main()
{

	int len,i,j,maxhigh=0;
	string s;
	int c[26];
	memset(c,0,sizeof(c));

	while (cin>>s)
	{
		len=s.length();
		for(i=0;i<len;i++)
			if(s[i]>=65 && s[i]<=90)
				++c[s[i]-'A'];
	}


	for(i=0;i<26;i++)
		if(maxhigh<c[i])
			maxhigh=c[i];

	for(i=maxhigh;i>0;i--)
	{
		for(j=0;j<26;j++)
			if(c[j]>=i)
				printf("* ");
			else
				printf("  ");
		printf("\n");
	}

	for(i=0;i<26;i++)
	{
		if(i>0)
			printf(" ");
		printf("%c",i+'A');
	}

	printf("\n");
	return 0;
}



Description

Write a program to read four lines of upper case (i.e., all CAPITAL LETTERS) text input (no more than 72 characters per line) from the input file and print a vertical histogram that shows how many times each letter (but not blanks, digits, or punctuation) appears in the all-upper-case input. Format your output exactly as shown.

Input

* Lines 1..4: Four lines of upper case text, no more than 72 characters per line.

Output

* Lines 1..??: Several lines with asterisks and spaces followed by one line with the upper-case alphabet separated by spaces. Do not print unneeded blanks at the end of any line. Do not print any leading blank lines. 

Sample Input

THE QUICK BROWN FOX JUMPED OVER THE LAZY DOG.
THIS IS AN EXAMPLE TO TEST FOR YOUR
HISTOGRAM PROGRAM.
HELLO!

Sample Output

                            *
                            *
        *                   *
        *                   *     *   *
        *                   *     *   *
*       *     *             *     *   *
*       *     * *     * *   *     * * *
*       *   * * *     * *   * *   * * * *
*     * * * * * *     * * * * *   * * * *     * *
* * * * * * * * * * * * * * * * * * * * * * * * * *
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

POJ 2136 Vertical Histogram

标签:acm   c++   poj   

原文地址:http://blog.csdn.net/u011694809/article/details/46537183

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!