码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-1251

时间:2015-06-19 22:55:51      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 21814    Accepted Submission(s): 9297


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

 

Sample Input
banana
band
bee
absolute
acm
 
ba
b
band
abc
Sample Output
2 3 1 0
 

 

Author
Ignatius.L
 
/**
          题意:如题
          做法:trie树 G++ MLE了n次 C++ AC 与AC自动机建树相同
**/
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <cmath>
using namespace std;
struct node
{
    int Count;
    node *next[26];
    node()
    {
        memset(next,NULL,sizeof(next));
        Count = 0;
    }
};
node *p,*root = new node();
void Insert(char *s)
{
    int i,k;
    for(p = root,i=0; s[i]; ++i)
    {
        k = s[i] -a;
        if(p->next[k] == NULL) p->next[k] = new node();
        p = p->next[k];
        p->Count++;
    }
}
int Search(char *s)
{
    int i,k;
    for(p = root,i=0; s[i]; i++)
    {
        k = s[i] -a;
        if(p->next[k] == NULL) return 0;
        p = p->next[k];
    }
    return p->Count;
}
int main()
{
//#ifndef ONLINE_JUDGE
//          freopen("in.txt","r",stdin);
//#endif
    char s[20];
    root = new node();
    while(1)
    {
                    cin.getline(s,20);
                    if(strcmp(s,"") == 0) break;
        Insert(s);
    }
    int tt = 0;
    while(1)
    {
                    cin.getline(s,20);
                    if(strcmp(s,"") == 0) break;
        printf("%d\n",Search(s));
    }
    return 0;
}

 

HDU-1251

标签:

原文地址:http://www.cnblogs.com/chenyang920/p/4589788.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!