码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-1671

时间:2015-06-19 22:55:16      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12684    Accepted Submission(s): 4307


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

 

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
 
Sample Output
NO YES
 Source
/**
          题意:给出n个电话号码,要求是否存在有的号码是另外一个字符串的前缀
          做法:Trie树  一直是RE 是把主函数的root = new node() 写成 p = new node()
                    然后 C++MLE 然后每次询问完删除树就OK
**/
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <cmath>
using namespace std;
char ch[10005][12];
struct node
{
          int count;
          node *next[10];
          node()
          {
                    count = 0;
                    for(int i=0;i<10;i++)
                    {
                              next[i] = NULL;
                    }
          }
};
node *root = new node(),*p;
void insert(char *s)
{
          p = root;
          for(int i=0;i<strlen(s);i++)
          {
                    int tt = s[i] -0;
                    if(p->next[tt] == NULL) p->next[tt] = new node();
                    p = p->next[tt];
                    p->count++;
          }
}
int find(char *c)
{
          int i;
          p = root;
          int len = strlen(c);
          for(i=0;i<len;i++)
          {
                    int tt = c[i]-0;
                    if(p->next[tt]->count== 1) break;
                    p = p->next[tt];
          }
          if(i == len) return 0;
         else  return 1;
}
void freedom(node *pp)
{
          for(int i=0;i<10;i++)
          {
                    if(pp->next[i] != NULL)
                    freedom(pp->next[i]);
          }
          free(pp);
}
int main()
{
      //   freopen("in.txt","r",stdin);
          int T;
          scanf("%d",&T);
          while(T--)
          {
                    root  = new node();
                    int n;
                    bool flag = true;
                    scanf("%d",&n);
                    for(int i=0;i<n;i++)
                    {
                              scanf("%s",ch[i]);
                              insert(ch[i]);
                    }
                    for(int i=0;i<n;i++)
                    {
                              if(find(ch[i]) == 0)
                              {
                                        flag = false;
                                        break;
                              }
                    }
                    if(!flag) printf("NO\n");
                    else printf("YES\n");
                    freedom(root);
          }
          return 0;
}

 

 

HDU-1671

标签:

原文地址:http://www.cnblogs.com/chenyang920/p/4589805.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!