码迷,mamicode.com
首页 > 其他好文 > 详细

BestCoder Round #45 (1,2)

时间:2015-06-21 00:50:17      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:bestcoder


比赛链接:http://bestcoder.hdu.edu.cn/contests/contest_show.php?cid=604

Dylans loves numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 94    Accepted Submission(s): 67



Problem Description
Who is Dylans?You can find his ID in UOJ and Codeforces.
His another ID is s1451900 in BestCoder.

And now today‘s problems are all about him.

Dylans is given a number N.
He wants to find out how many groups of "1" in its Binary representation.

If there are some "0"(at least one)that are between two "1",
then we call these two "1" are not in a group,otherwise they are in a group.
 
Input
In the first line there is a number T.

T is the test number.

In the next T lines there is a number N.

0N1018,T1000
 
Output
For each test case,output an answer.
 
Sample Input
1 5
 
Sample Output
2
 
Source
BestCoder Round #45

题目大意:求一个数字二进制中多少个连续的1群体

题目分析:直接模拟


#include <cstdio>
#define ll long long

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        ll n;
        scanf("%I64d", &n);
        int cnt = 0;
        bool flag = true;
        while(n != 0)
        {
            if((n & 1) ^ 0)
            {
                if(flag)
                    cnt ++;
                flag = false;
            }
            else
                flag = true;
            n >>= 1;
        }
        printf("%d\n", cnt);
    }
}


 

Dylans loves sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 195    Accepted Submission(s): 105



Problem Description
Dylans is given N numbers a[1]....a[N]

And there are Q questions.

Each question is like this (L,R)

his goal is to find the “inversions” from number L to number R.

more formally,his needs to find the numbers of pair(x,y),
that L≤x,y≤R and x<y and a[x]>a[y]
 
Input
In the first line there is two numbers N and Q.

Then in the second line there are N numbers:a[1]..a[N]

In the next Q lines,there are two numbers L,R in each line.

N≤1000,Q≤100000,L≤R,1≤a[i]≤231?1
 
Output
For each query,print the numbers of "inversions”
 
Sample Input
3 2 3 2 1 1 2 1 3
 
Sample Output
1 3
Hint
You shouldn‘t print any space in each end of the line in the hack data.
 

Source
 
题目大意:求区间逆序数对数

题目分析:用dp[i][j]预处理,先算区间[i,j]中与a[i]成逆序对的数目,然后从后向前累加
,相当于加一个a[j],看它对整个区间的逆序数对数是否有影响

#include <cstdio>
#include <cstring>
int const MAX = 1005;
int dp[MAX][MAX];
int a[MAX];

int main()
{
    int n, q;
    scanf("%d %d", &n, &q);
    for(int i = 1; i <= n; i++)
        scanf("%d", &a[i]);
    memset(dp, 0, sizeof(dp));
    for(int i = 1; i <= n; i++)
        for(int j = i; j <= n; j++)
            dp[i][j] += (dp[i][j - 1] + (a[i] > a[j] ? 1 : 0));
    for(int j = n; j > 0; j--)
       for(int i = j; i > 0; i--)
            dp[i][j] += dp[i + 1][j];
    while(q--)
    {
        int l, r;
        scanf("%d %d", &l, &r);
        printf("%d\n", dp[l][r]);
    }
}


BestCoder Round #45 (1,2)

标签:bestcoder

原文地址:http://blog.csdn.net/tc_to_top/article/details/46576591

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!