码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1853 Cyclic Tour(最小费用最大流)

时间:2015-06-25 23:06:18      阅读:357      评论:0      收藏:0      [点我收藏+]

标签:图论   算法   费用流   

Cyclic Tour

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/65535 K (Java/Others)
Total Submission(s): 1879    Accepted Submission(s): 938


Problem Description
There are N cities in our country, and M one-way roads connecting them. Now Little Tom wants to make several cyclic tours, which satisfy that, each cycle contain at least two cities, and each city belongs to one cycle exactly. Tom wants the total length of all the tours minimum, but he is too lazy to calculate. Can you help him?
 

Input
There are several test cases in the input. You should process to the end of file (EOF).
The first line of each test case contains two integers N (N ≤ 100) and M, indicating the number of cities and the number of roads. The M lines followed, each of them contains three numbers A, B, and C, indicating that there is a road from city A to city B, whose length is C. (1 ≤ A,B ≤ N, A ≠ B, 1 ≤ C ≤ 1000).
 

Output
Output one number for each test case, indicating the minimum length of all the tours. If there are no such tours, output -1.
 

Sample Input
6 9 1 2 5 2 3 5 3 1 10 3 4 12 4 1 8 4 6 11 5 4 7 5 6 9 6 5 4 6 5 1 2 1 2 3 1 3 4 1 4 5 1 5 6 1
 

Sample Output
42 -1
Hint
In the first sample, there are two cycles, (1->2->3->1) and (6->5->4->6) whose length is 20 + 22 = 42.
 

Author
RoBa@TJU
 

Source
题意:给一个有向图,问每个点都只在一个简单环上,可以有多个环,边权总和最小为多少,如果不满足条件就输出-1。
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int MAXN = 10010;
const int MAXM = 100100;
const int INF = 1<<30;
struct EDG{
    int to,next,cap,flow;
    int cost;  //每条边的单价
}edg[MAXM];
int head[MAXN],eid;
int pre[MAXN], cost[MAXN]  ; //点0~(n-1)

void init(){
    eid=0;
    memset(head,-1,sizeof(head));
}
void addEdg(int u,int v,int cap,int cst){
    edg[eid].to=v; edg[eid].next=head[u]; edg[eid].cost = cst;
    edg[eid].cap=cap; edg[eid].flow=0; head[u]=eid++;

    edg[eid].to=u; edg[eid].next=head[v]; edg[eid].cost = -cst;
    edg[eid].cap=0; edg[eid].flow=0; head[v]=eid++;
}

bool inq[MAXN];
bool spfa(int sNode,int eNode,int n){
    queue<int>q;
    for(int i=0; i<n; i++){
        inq[i]=false; cost[i]= INF;
    }
    cost[sNode]=0; inq[sNode]=1; pre[sNode]=-1;
    q.push(sNode);
    while(!q.empty()){
        int u=q.front(); q.pop();
        inq[u]=0;
        for(int i=head[u]; i!=-1; i=edg[i].next){
            int v=edg[i].to;
            if(edg[i].cap-edg[i].flow>0 && cost[v]>cost[u]+edg[i].cost){ //在满足可增流的情况下,最小花费
                cost[v] = cost[u]+edg[i].cost;
                pre[v]=i;   //记录路径上的边
                if(!inq[v])
                    q.push(v),inq[v]=1;
            }
        }
    }
    return cost[eNode]!=INF;    //判断有没有增广路
}
//反回的是最大流,最小花费为minCost
int minCost_maxFlow(int sNode,int eNode ,int& minCost,int n){
    int ans=0;
    while(spfa(sNode,eNode,n)){
        ans++;
        for(int i=pre[eNode]; i!=-1; i=pre[edg[i^1].to]){
            edg[i].flow+=1; edg[i^1].flow-=1;
            minCost+=edg[i].cost;
        }
    }
    return ans;
}
void scanf(int &ans){
    char ch;
    while(ch=getchar()){
        if(ch>='0'&&ch<='9')
            break;
    }
    ans=ch-'0';
    while(ch=getchar()){
        if(ch<'0'||ch>'9')
            break;
        ans=ans*10+ch-'0';
    }
}
int  mapt[1005][1005];
int main(){
    int n,m , u, v, d ;
    while(scanf("%d%d",&n,&m)>0){
        init();
        int s=0, t=2*n+1;

        for(int i=1; i<=n; i++){
            addEdg(s , i , 1 , 0);
            addEdg(i+n , t , 1 , 0);
            for(int j=1; j<=n; j++)
                mapt[i][j]=INF;
        }
        while(m--){
            scanf(u); scanf(v); scanf(d);
            if(mapt[u][v]>d)
                mapt[u][v]=d;
        }
        for( u=1; u<=n; u++)
            for(v=1; v<=n; v++)
            if(mapt[u][v]!=INF)
                addEdg(u,v+n,1,mapt[u][v]);

        int mincost=0;
       n-= minCost_maxFlow(s , t , mincost , t+1);
        if(n==0)
            printf("%d\n",mincost);
        else
            printf("-1\n");
    }
}


HDU 1853 Cyclic Tour(最小费用最大流)

标签:图论   算法   费用流   

原文地址:http://blog.csdn.net/u010372095/article/details/46641421

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!